I finally made it around to upgrading WordPress to 2.8.2 and it seems to be working like a charm. It looks like there were some bug fixes and a XSS vulnerability was patched.